286: satori_savedata.txtがインストールされない

ばぐとら研究所統合ToDo管理システムへようこそ!バグ報告に限らず様々な要望を扱うシステムです。
まずは同じような内容がないか [検索] した後、無ければ [新規レポート] で作ってみましょう。
Windows 8以降、高速スタートアップが実装された関係で、SSP以外の部分に起因する不具合発生が出てきました。
何か挙動がおかしいかな、と思ったら、一度再起動(シャットダウン->起動ではなく)してみてから再度確かめてみてください。

最新状況

名前 ぽな@ばぐとら
概要 satori_savedata.txtがインストールされない
状態 [×]対応不能
作成日時 2011-02-15 23:49:00
最終更新日時 2011-02-17 06:26:44

履歴

1 | 2011-02-15 23:49:00 | [−]新規
深瀬
アーカイヴに含まれているsatori_savedata.txtが
インストールされないようです。(ssp2.02〜ssp2.02.47)
里々ゴーストに限らず、華和梨ゴーストのアーカイヴにも
satori_savedata.txtという名前のファイルを入れて
試してみましたが排除されました。
ファイルネームでインストールから除外するのはやりすぎ
なのでは・・・。
拙作ドウメキ(narファイル版)はそのために不具合が出ています。

2 | 2011-02-16 01:48:47 | [−]新規
深瀬
あーすいません、こちらでなんとかします。

3 | 2011-02-16 01:56:31 | [−]新規
Don
>ベースウェアメンテナさまへ
里々ゴーストマスタの一人として、
現状の仕様に対して好意的な意見を持っていることを念のため申し添え
ておきます。

ttp://nar.jpn.org/test/read.cgi/unyu/1096732024/491-495

今まで動いていたゴーストが動かなくなる現象をバグと定義するのであ
ればそのように、
里々Mc143-4での変更のように互換性を犠牲にしてでも多数の利益のため
にやむなしとするならそのように。

どちらを優先するかはメンテナ様へお任せしますが、
そのように仕様を変更した際はSSP CHANGELOGにでも(設計思想と併せて
)明記して頂けると
無用なトラブルを未然に防ぐことに加え、利害関係者からの理解も得や
すいのではないかと存じます。

>深瀬さまへ
ご理解ありがとうございます。

4 | 2011-02-17 06:26:44 | [×]対応不能
ぽな@ばぐとら
下記のように、別OSデータやらゴミファイルやらのフィルタ処理の一環
です。
updates2.dauのように更新ファイル自体を更新してしまうとまずいの
で、それも除外されています。

static const FileCheckTable dontCopyFileTable[] = {
  //1234567890123456789012345
  {"ngm.dat"                 ,7 },    //NGM
  {"thumbs.db"               ,9 },    //Thumbnail
  {".DS_Store"               ,9 },    //DropStuff
  {"folder.htt"              ,10},    //フォルダのカスタマイズ
  {"desktop.ini"             ,11},    //ディレクトリの設定、らしい。
  {"mscreate.dir"            ,12},    //何これ?
  {"_CATALOG.VIX"            ,12},    //VIX
  {"updates2.dau"            ,12},    //updates
  {"aya5_variable.cfg"       ,17},    //AYA5
  {"yaya_variable.cfg"       ,17},    //YAYA
  {"yaya_variable.ays"       ,17},    //YAYA
  {"satori_savedata.txt"     ,19},    //SATORI
  {"satori_savedata.sat"     ,19},    //SATORI
};

設計思想なんてせいぜいこの程度でありまして……
どうしても何かのっぴきならない理由があるなら考えますが、どちらか
というと「本来含んでいてはまずいファイル」扱いです。

[リプライをつける]
Bug Tracking System 影舞 0.8.8
Powered by Ruby 1.8.7